Applet Run Delays
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 25, 2017 - 15:35 PDT
Identified
All applets are running delayed, we are actively working on getting everything back to full speed.
Posted 3 months ago. Sep 25, 2017 - 14:43 PDT