The JotForm service is currently paused
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 13 days ago. Nov 30, 2017 - 08:21 PST
Investigating
Paused services may be experiencing technical difficulties. All Applets using these services will resume once the technical difficulties are resolved.
Posted 14 days ago. Nov 29, 2017 - 09:09 PST