Issues Loading ifttt.com
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 4 months ago. May 09, 2017 - 16:44 PDT
Investigating
We are currently investigating this issue.
Posted 4 months ago. May 09, 2017 - 16:33 PDT