Issues loading IFTTT.com and Mobile Apps
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 26 days ago. Nov 17, 2017 - 09:30 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 27 days ago. Nov 16, 2017 - 17:51 PST
Investigating
We're experiencing issues loading ifttt.com and are currently looking into the issue.
Posted 27 days ago. Nov 16, 2017 - 17:34 PST