Instagram Applets Delayed
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 9 months ago. Mar 08, 2017 - 09:36 PST
Investigating
Applets which use Instagram triggers may be delayed. We are investigating the issue.
Posted 10 months ago. Mar 03, 2017 - 13:44 PST