The SurveyMonkey service is currently paused
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 14 days ago. Jan 06, 2018 - 07:41 PST
Identified
SurveyMonkey is undergoing maintenance during which it is unavailable - https://help.surveymonkey.com/articles/en_US/kb/Site-Maintenance
Posted 15 days ago. Jan 05, 2018 - 19:13 PST