IFTTT is intermittently unavailable
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 6 months ago. May 09, 2017 - 15:55 PDT
Investigating
We are currently investigating this issue.
Posted 6 months ago. May 09, 2017 - 15:47 PDT