Issues Loading ifttt.com
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 6 months ago. Apr 28, 2017 - 13:39 PDT
Investigating
We are currently investigating this issue.
Posted 6 months ago. Apr 28, 2017 - 13:29 PDT