Emails are currently delayed
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 23 days ago. Jan 30, 2018 - 11:24 PST
Investigating
Emails sent using the Email service are currently experiencing a delay in being sent
Posted 23 days ago. Jan 30, 2018 - 08:22 PST