Flickr is paused for maintenance
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 5 months ago. Jul 19, 2017 - 18:24 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted 5 months ago. Jul 19, 2017 - 12:27 PDT
Investigating
We are currently investigating this issue.
Posted 5 months ago. Jul 19, 2017 - 12:27 PDT