Instagram triggers may be delayed
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 25, 2017 - 08:19 PDT
Investigating
We are currently investigating this issue.
Posted 3 months ago. Jul 24, 2017 - 16:57 PDT