Applet run delays
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 27, 2017 - 17:09 PDT
Investigating
All applets are running delayed, we are actively working on getting everything back to full speed.
Posted 3 months ago. Sep 27, 2017 - 16:48 PDT