Applet run delays
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted about 1 month ago. Oct 17, 2017 - 11:48 PDT
Monitoring
Some applets are running delayed, we are actively working on getting everything back to full speed.
Posted about 1 month ago. Oct 17, 2017 - 07:55 PDT