The Concur Labs service is currently paused
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 27, 2017 - 20:29 PDT
Investigating
Paused services may be experiencing technical difficulties. All Applets using these services will resume once the technical difficulties are resolved.
Posted 5 months ago. Jan 20, 2017 - 16:54 PST