Issues Loading IFTTT.com
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted Jun 13, 2017 - 23:37 PDT
Investigating
We're experiencing issues loading ifttt.com and are currently looking into the issue.
Posted Jun 13, 2017 - 23:22 PDT