Applets Run Delays
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 16 days ago. Nov 27, 2017 - 15:26 PST
Investigating
Some applet runs are delayed, we are currently working on the issue.
Posted 16 days ago. Nov 27, 2017 - 15:08 PST