Instagram triggers may be delayed
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted about 1 month ago. Dec 14, 2017 - 09:40 PST
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Dec 14, 2017 - 09:24 PST