Notifications Delays
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 24 days ago. Oct 26, 2017 - 18:50 PDT
Update
We're experiencing an elevated level of delays in Activity Logs and are currently looking into the issue.
Posted 25 days ago. Oct 26, 2017 - 18:17 PDT
Identified
We're experiencing an elevated level of delays in Notifications and are currently looking into the issue.
Posted 25 days ago. Oct 26, 2017 - 18:17 PDT