The Instagram service is currently paused
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 9 days ago. Jan 11, 2018 - 16:48 PST
Investigating
We're investigating an "image not found" issue with Instagram, stay tuned for updates and thank you for your patience!
Posted 9 days ago. Jan 11, 2018 - 10:48 PST