Emails are delayed
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 28, 2017 - 16:37 PDT
Investigating
We are currently investigating this issue.
Posted 3 months ago. Jul 28, 2017 - 14:48 PDT