Issues Loading IFTTT.com
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 8 days ago. Dec 05, 2017 - 10:45 PST
Investigating
We're experiencing issues loading ifttt.com and are currently looking into the issue.
Posted 8 days ago. Dec 05, 2017 - 10:40 PST