Applet runs are experiencing delays
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 6 months ago. May 09, 2017 - 17:17 PDT
Investigating
We are currently investigating this issue.
Posted 6 months ago. May 09, 2017 - 16:58 PDT