Issues Loading IFTTT.com
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 26 days ago. Sep 25, 2017 - 13:41 PDT
Investigating
We're experiencing issues loading ifttt.com and are currently looking into the issue.
Posted 26 days ago. Sep 25, 2017 - 13:41 PDT