Emails from the Email service are delayed
Incident Report for IFTTT
Resolved
This incident has been resolved.
Posted 9 days ago. Aug 08, 2017 - 09:49 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted 9 days ago. Aug 08, 2017 - 09:03 PDT