Issue that affected the IFTTT Email service's Send me an email action
Incident Report for IFTTT
Resolved
We are investigating an issue that prevented some Applets using the IFTTT Email service's Send me an email action from running between March 21st to March 22nd.

This issue has now been resolved and Email actions should be running as expected.
Posted Mar 21, 2024 - 08:30 PDT